Getting Dovecot to work (IMAP)

May 29, 2014 1.7k views
I have installed Webmin on a droplet, and imported my old cPanel account from my old server. Pretty much everything is fine, but i'm having problems with IMAP. Basically, the whole mailbox imported fine, and I can access it all via the webmail with no real issue. Even STMP works fine. But for some reason, i cannot get IMAP to work. If i point it to the same name as STMP (, i get a generic "could not connect to the IMAP server" error. If i set it to the hostname of the server ( on port 993, I get "Trying to log into this IMAP account failed. Verify the user/pass are correct." They are definitely correct, as I checked the username in webmin, and I reset the password to be sure. Any ideas?
6 Answers
What username are you using to connect via IMAP? Does this help?
Kamal: I've already checked that article and I am 100% certain i'm using the correct username as listed under Users.
I've never used Virtualmin but have you tried using the full email address as the username?
Yes, that's what I originally tried, and that doesn't work either.
Are those error messages from your local mail client? What are you using?

The first thing I'd check is whether port 993 is actually accessible. Are you doing any firewalling? What's the output of running netstat -plunt on the server?
Yes, those error messages are (rougly copied) from OSX's

I'm considering giving up with Virtualmin and setting these things up from scratch though. If i restore my snapshot and try again, i'll check this.
Have another answer? Share your knowledge.