git push dokku master requires password

Posted January 14, 2016 5.2k views

I’ve got Ubuntu 14.04 droplet. I try to push the app to dokku repo, but it requests password, which I don’t have.
What I do:
git clone
git remote add dokku dokku@myhostname:myapp

And it requires:’s password:

I’ve seen people suggesting doing following:
cat ~/.ssh/ | ssh root@myhostname “sudo sshcommand acl-add dokku [description]” - I tried running it from my computer (not on root@my_hostname) - but it didn’t help.

What could be the problem? Any ideas on how to troubleshoot?

1 comment
  • Try running that command on the dokku host, and not localy:

    cat ~/.ssh/ | sudo sshcommand acl-add dokku admin - I tried running it from my computer (not on root@my_hostname) - but it didn't help.

    Note that the installation process for dokku should provide you with a web ui at that host.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Solved myself. Didn’t understand that git push dokku master has to be done from local, not from server.

I followed the command line

cat ~/.sshauthorized_keys/ | ssh root@{droplet_ip} "sudo sshcommand acl-add dokku admin"

When I do , git push dokku master
Password is still asked.

dokku@{droplet_ip}'s password: 

So what did you exactly do ?