GitLab 6.3 CE Droplet - SSH Push fails

Pushing to a fresh install of gitlab with the application image from DigitalOcean fails with Access denied. fatal: Could not read from remote repository.

Please make sure you have the correct access rights and the repository exists.

I used the DigitalOcean guide to setup the installation:

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I had this issue, it turned out that the git repository wasn’t being cerated at all in /var/opt/gitlab/git-data/repositories restarting the server fixed it for me, not sure why.

shutdown -r now

git push -u origin master <br> <br>I also tried Git-Tower (Git-Client for Mac) => same issue

I’ve just tried pushing to a gitlab repo and it worked (fresh GitLab droplet). What command are you trying to run?