Question

Gunicorn increase timeout doesnt takes effect

  • Posted February 28, 2022
  • Flask

I have a minimal flask api deployed on digital ocean wich trhows this error when i do a large request:

[1] [CRITICAL] WORKER TIMEOUT (pid:16)

I tried:

/env/Lib/site-packages/gunicorn-config.py (0 is unlimited,but i tried 500 etc)

class Timeout(Setting):
    name = "timeout"
    section = "Worker Processes"
    cli = ["-t", "--timeout"]
    meta = "INT"
    validator = validate_pos_int
    type = int
    default = 0
    desc = """\

gunicorn_config.py

bind = "0.0.0.0:8080"
workers = 2
timeout = 300

Procfile

web: gunicorn app:app --timeout 300

But i get the same error on the digital ocean console,and on the browser frontend i get the 504 error after about 30 secs wich means im not overwriting the 30 seconds gunicorn default. Smaller/faster requests they work good.

Any idea what can be the issue? Thanks so much!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hey @floatingbluegreenjellyfish,

Setting the timeouts in the run command should work.

But note that there is a hard set 100s timeout in the App platform for requests that unfortunately can’t be changed.

However, if the request is timing out in 30 seconds that could be due to resource exhaustion.

Please reach out to our amazing support team who will be more than happy to assist you with this :)

https://www.digitalocean.com/support/

Hope that helps!

- Bobby.