Question

Having some difficulties settings up vanity nameservers

Posted October 7, 2021 103 views
DNS

Hello,

Im working on a web app which lets people create their own websites, with the ability to link their own domain names to my web app, and ive decided to use custom nameservers (the users have to enter my custom nameservers in their registrar settings to link their domain names to my web app).
I followed the tutorial on this link:
https://www.digitalocean.com/community/tutorials/how-to-create-vanity-or-branded-nameservers-with-digitalocean-cloud-servers
And i have setup my Glue records (from GoDaddy), and i’ve edited the required
settings on DigitalOcean

here are my DNS settings:
A ns3.myapp.com 198.41.222.173 3600
A ns2.myapp.com 173.245.59.41 3600
A ns1.myapp.com 173.245.58.51 3600
A *.myapp.com 165.22.67.246 3600
A myapp.com 165.22.67.246 3600
NS myapp.com ns3.myapp.com. 1800
NS myapp.com ns1.myapp.com. 1800
NS myapp.com ns2.myapp.com. 1800

Next, i purchased a seperate domain name from OnyDomains to link it to one my test websites, i entered ns1.myapp.com and ns2.myapp.com, i waited for a very long while until the DNS records have changed, but it doesnt work.
Is there anything wrong with my DNS settings ?

Thank you!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hey there!

It sounds like you have things properly configured with your DNS. However without knowing the domains being used it is hard to confirm that. Rather then sharing those here I’d recommend opening a ticket with our support team that can double check your domains DNS configuration and offer further insights.

Hope that helps!
Nate