How to connect managed Postgres db to Google Looker Studio

I was following the documentation in to get my connection to work, but for some reason i receive this message.

Sorry, we encountered an error and were unable to complete your request.

Error ID: 82f94123

what can I do?

what I have tried:

  • checking the connection credentials and test with another software (pgadmin)
  • adding google ip addresses to the firewall in DigitalOcean
  • Created a test database with each Postgres version from 8 to 14.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
May 19, 2024

Hey @noedolphin,

I’ve noticed a similar discussion here which was just due to a temporary issue on the Looker end:

If you were to try now does it work?

The error is very vague and hard to pinpoint what might be going on. Have you tried temporarily disabling the trusted sources of your cluster to see if Looker is able to connect when the database cluster is open for all incoming connections?

Let me know how it goes!

- Bobby.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel