How to display Domain Name instead of IP Address?

February 7, 2015 4.1k views

I have a droplet with wordpress running for the domain:
ip address:

My Zone file:
$TTL 1800 IN SOA 1423320920 10800 3600 604800 1800 1800 IN NS 1800 IN NS 1800 IN NS 1800 IN A 1800 IN AAAA 2604:a880:800:10::1 1800 IN CNAME
* 1800 IN CNAME 1800 IN A

I've read through many tutorials but have been unable to resolve the issue myself.
When I change the settings within wordpress for Site/Home URL I'm no longer able to to login to my site. I believe I may need to make further changes under mysql and php admin?
I've also seen some suggestions regarding needing to add a server alias to Apache?

Is there any additional info I need to provide?

Can someone please describe the proper process to go through in detail?

I know I've seen a lot of people with this very issue, it may prevent the question from being asked a lot if a definitive guide could be posted.

  • If you have only just recently made the changes to your DNS, then just be patient. It can take some time. Sleep on it and try again tomorrow.

    If you made the changes a few days ago, and it is still not working, are you sure you set digitalocean nameservers with your domain registrar?

  • @sierracircle Thanks for responding :)

    1. The changes are old. I've been working on the rest of the site locally and sort of putting this part off.

    2. I'm sure I set the digital ocean nameservers (e.g., ns2.., ns3..) with my domain registrar.

2 Answers


Log in to your WordPress admin dashboard and navigate to Settings -> General. You should see two fields named "WordPress address (URL)" and "Site address (URL)", replace your Droplet's IP address with your domain name.

Have another answer? Share your knowledge.