How to install an ssl certificate from Rapid ssl authority in Ubuntu 14 for magento?

May 31, 2015 955 views
Apache Security Ubuntu

I have installed the Rapid ssl in my Ubuntu 14.04.2 LTS. But the website is not loading after that. I am getting following message in browser "The page isn't redirecting properly"

my apache version is apache 2.4.7

The conf file is available in /etc/apache2/sites-available/magento.conf is as follows

<VirtualHost *:80>
ServerName mysite.co.uk
Redirect permanent / https://mysite.co.uk/
</VirtualHost>
<VirtualHost *:443>
ServerName www.mysite.co.uk
SSLEngine on
SSLProtocol all
SSLCertificateFile /etc/apache2/ssl/rapidsslpublickey2015.crt
SSLCertificateKeyFile /etc/apache2/ssl/private.key
SSLCertificateChainFile /etc/apache2/ssl/rapidsslintermediateca2015.crt
ErrorLog ${APACHELOGDIR}/error.log
CustomLog ${APACHELOGDIR}/access.log combined
<Directory /var/www/html/magento>
AllowOverride All
Require all granted
</Directory>

</VirtualHost>
vim: syntax=apache ts=4 sw=4 sts=4 sr noet

The ports.conf available in /etc/apache2/ports.conf as follows

Listen 80

<IfModule ssl_module>
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>
vim: syntax=apache ts=4 sw=4 sts=4 sr noet

The apache error log I could see as follows:
[Fri May 29 23:42:51.054552 2015] [ssl:warn] [pid 2048] AH01909: RSA certificate configured for www.funnfrolic.co.uk:443 does NOT include an ID which matches the server name
[Fri May 29 23:42:51.054975 2015] [ssl:warn] [pid 2048] AH01909: RSA certificate configured for www.funnfrolic.co.uk:443 does NOT include an ID which matches the server name
[Fri May 29 23:42:51.055076 2015] [ssl:warn] [pid 2048] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri May 29 23:42:51.222699 2015] [ssl:warn] [pid 2053] AH01909: RSA certificate configured for www.funnfrolic.co.uk:443 does NOT include an ID which matches the server name
[Fri May 29 23:42:51.223298 2015] [ssl:warn] [pid 2053] AH01909: RSA certificate configured for www.funnfrolic.co.uk:443 does NOT include an ID which matches the server name
[Fri May 29 23:42:51.223512 2015] [ssl:warn] [pid 2053] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri May 29 23:42:51.227454 2015] [mpm_prefork:notice] [pid 2053] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.6 OpenSSL/1.0.1f configured -- resuming normal operations
[Fri May 29 23:42:51.227484 2015] [core:notice] [pid 2053] AH00094: Command line: '/usr/sbin/apache2'

Can you please guide me how we can resolve this? I have hosted the website in Digital Ocean. Also- everytime when I restart the apache- I could see following message and I am giving passphrase everytime. Is that something have any impact in the process?

Apache needs to decrypt your SSL Keys for www.funnfrolic.co.uk:443 (RSA)
Please enter passphrase:

1 Answer

The password on your key would not cause these problems but the way it is configured you will need to enter the password when restarting apache.

Generally a redirect error would have to do with a rewrite configuration. Since you don't seem to have this in your apache configuration directly it is likely in an .htaccess file in your web root. I would recommend reviewing those redirect settings and also any configuration within Magento itself that may be setting a default web path.

Have another answer? Share your knowledge.