Question

How to solve: Uploaded file exceeds upload_max_filesize directive in php.ini.?

Hello, I was installing a wordpress plugin and the following message appears Uploaded file exceeds upload_max_filesize directive in php.ini.?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @vitturx-business,

You need to increase the values of two options in your php.ini:

  • upload_max_filesize
  • post_max_size

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of upload_max_filesize and post_max_size you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 200M
post_max_size = 200M```

You also need to restart your web server in order the changes to take effect.