how to speedup uploads?

I’m getting crazy my upload speeds to my wordpress is ridicule. I have a 500mb connection, and i know droplet as good speeds. For example a 5 Mb file transfer almost immediately on filezilla by ftp, but with wordpress normally gets stuck. Is this a wordpress bug? Is there a way to bypass this? If not i’m seriously considering giving up on Wordpress Thanks.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@luisSquid All right? Managed to solve? I’m having the same ridiculous problem and Digital doesn’t answer any of these amazing topics!

well i just let the file upload and went to dinner (1462kb) after over 1hour it was still in 80%, after a long time close to 2hours it finally finished.

I already had made the changes suggested to php, it gets a little better but still unacceptable.

About the browser tried firefox and chrome, and i’m running DigitalOcean 1 click install OpenLiteSpeed WordPress VERSION 5.3.2 OS Ubuntu 18.04

I set it up specially to try and tackle this. i have the same issue on a managed shared server, I thought it might be some limitations from there but its not, exactly the same here same here.

PS: it goes fast to about 40% and then stops for long time and then it goes really slow, tried different upload plugin but all with the same result.

but with wordpress normally gets stuck.

How does it get stuck? Does it stop, or uploads slowly? Check the logs to see if WordPress is telling about any problem with the current stack and configuration.

a 5 Mb file transfer almost immediately on filezilla by ftp

FTP is a native TCP protocol that uses a bare TCP stream to transfer the data. Your 500 MBPS (ps, right?) connection has a good throughput to upload a 5 MB file immediately.

WordPress relies on several layers before the packet can be sent. You are using WordPress on a web browser, which in turn is based on a runtime/language and that uses the OS stack to transmit the data on TCP protocol. Still, it should not be this much slow, maybe 1-4 seconds to upload a file, maximum.

Try this SO thread and see if this works.

Try changing the browser, or better, see if there are any bandwidth limitations on the service.

Which OS are you using?