Question

How to upgrade Mattermost 5.12.0 on Ubuntu 18.04 droplet

Hello

Forgive what may be a super easy question but I’m currently running the Mattermost 5.12.0 on Ubuntu 18.04 droplet. I’m getting a server update error telling me to upgrade to server version 5.19 or later. How do I do so within Digital Ocean?

Subscribe
Share

Does it show an update available with the common:

apt update

If yes use

apt full-upgrade

That will upgrade everything, alternatively you can use

apt upgrade {package name}


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

There seems to be no way to upgrade a Mattermost Digital Ocean droplet. Is that the case?

Thanks for helping. Using apt full-upgrade it went through the motions with the green bar on the console going through to 100%, but according to the droplet its still “Mattermost 5.12.0 on Ubuntu 18.04”. I’m also still getting the server out of date error when opening the app.

Also the highest available version on DigitalOcean seems to be Mattermost 5.16.3

Any other ideas? Thanks again!