Question

HTTPS still not working after installing Certbot

  • Posted January 18, 2021
  • Nginx

I just finished following this tutorial: https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-18-04

But I still can’t get my server to work with https… are there more steps after this? Do I have to use my certificate/private key somewhere else to finish setting this up?

One side note tho… the certification was set to the domain name “highcalibersolution.com www.highcalibersolution.com” brought through namecheap and that is still not connected with my dropet (they said it takes about 48hours)… Will that might be the reason the HTTPS is not working? Because the domain isn’t fully connected with the droplet yet…

Thank you, let me know if I should share any error logs here that might be helpful

Subscribe
Share

Hello @MassiveAquamarineCrab,

Did you find any solution for this problem ?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi, @MassiveAquamarineCrab,

Until your DNS does not fully point to your Droplet with DigitalOcean, you might experience difficulties installing your SSL with Certbot.

If the installation of your SSL using Certbot was actually done it should’ve updated your Nginx configuration file so the problem might be there. I tried to open your website highcalibersolution.com however I was presented with a 500 Internal Server error. This again would suggest an issue with the configuration file.

As everything is pointing to the config file, can you please post a copy of it as a reply to this thread so that I can see what exactly is causing these issues?

Regards, KFSys