I cannot access my public ip via Nginx

May 13, 2018 100 views
Nginx Networking Ubuntu 18.04

Hi community,

I really need your help! i'm on the brink of losing my mind...

So after a few solid weeks of work i was able to get my flask app running and everything setup using Nginx / Gunicorn etc...everything looked really good and pretty much optimized to the way i wanted it...

Until a few hours ago i started playing around with my ufw settings to see where i could improve by cutting out access to unnecessary ports... low and behold i accidentally copied the sudo ufw reset line of code and my entire setup was reset. At the time i didn't think too much of it, i thought i could just quickly set everything up again, easy.

But now i cannot access my ip-server (public ip / wan ) anymore... Nginx works fine for localhost, 127.0.0.1, 0.0.0.0...etc...

Now i've traversed the whole web looking for answers...some of the solutions came from nginx.conf not being configured correctly, some of the solutions came from the isp not allowing port 80 etc... I'm open to exploring these as possiblities, but i just can't imagine that being the case.....

I can't even access my public ip with UFW disabled.
I've tried pinging nginx and i get 404 error.

I know it has something to do with my ufw reset...can anyone point me in the right direction as to where to look?

Thank you in advance.

2 comments
  • please....i'm very very desperate...this project is due tomorrow :'(

  • We cannot help you without more information, make sure you have DO firewall disabled or it allows access to port 80.

    If you needed more help you can contact me on my email address mohsen47@hotmail.co.uk

1 Answer

@Mohsen47 Thank you so much!! I feel incredibly silly at the moment... i never thought that DO firewall was the thing block me from both, joining ssh successfully and also blocking port 80.

I had it set-up after the fact everything was running correctly so i never considered it as the source of the issue. I also had everything set-up to inbound: ssh only and outbound: all ports tcp/udp etc...

But after removing it everything returned to normal!!! thank you.

Have another answer? Share your knowledge.