Question

I think my droplet is unable to connect with the internet...

Posted April 7, 2020 409 views
DigitalOcean

I tried to update the system but it says.. fail to fetch and all.
After that I ran ping www.google.com
It returns..

ping: www.google.com:Temporary failure in name resolution

Also I’m not able to reach my website which is running at port 8080.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @anurag1004

What happens when you execute ifconfig -a can you see the eth0 interface listed? If this one is not present then we will need to sort this out.

I know that sometimes some packages can be uninstalled somehow on reboot and there are cases where cloud-init is one of them. You can check if the package is present and currently installed on your droplet as well.

A similar issue was reported here as well: https://www.digitalocean.com/community/questions/no-internet-connection-after-droplet-reboot

You can check the answer posted from lukasea17033bb7e7ecf80fc21 and see the suggested steps if needed.

  1. Create the /etc/udev/rules.d/70-persistent-net.rules file
  2. Reboot tje server
  3. Set the network interface using the information from the /etc/netplan/50-cloud-init.yaml file
  4. Set the routing
  5. Configure the dns resolver conf file (you can skip this if your resolv conf is still present, I know you’ve mentioned that you’ve already copied this from a working droplet)
  6. You can run apt update and apt upgrade
  7. Install cloud-init if it’s missing and ufw and landscape:

sudo apt install cloud-init

sudo apt install ufw

sudo apt install landscape-common

Also have you tried to power off the droplet and then start it again instead of just rebooting it? You can perform this action from the control panel.

Let me know how it goes.

Regards,
Alex

  • Hey thanks for the answer :)
    But I found a mail from digital ocean which I received 3 days back, It says that my droplet was attacked with DDOS, so they had to disconnect my droplet from newtwork to prevent further harm

Submit an Answer