image upload to server does not work

I’m using in my app intervention image library from , its working very good on my localhost (pc) but image upload didn’t work on digital ocean server ! , so anyone have any idea why this problem happens to me


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

2017/05/15 21:47:43 [notice] 11790#11790: signal process started 2017/05/15 23:28:10 [notice] 1721#1721: signal process started 2017/05/16 09:02:06 [error] 1724#1724: *144 client intended to send too large body: 1214882 bytes, client:, ser ver:, request: “POST /profile/5 HTTP/1.1”, host: “”, referrer: “

what is that means ?

try to reboot server, not just restart the service… that will be work as well.

yes it looks exactly like this but i changed these two lines /etc/php/7.0/cli/php.ini:upload_max_filesize = 2M , to 100m and /etc/php/7.0/cli/php.ini:post_max_size = 8M , to 100m @hansen

i do every single command you mentions ! but it still not works ! im using image library , and stores the images inside the public/images folder , i give the permissions for this folder sudo chmod -R 775 /var/www/laravel/public/images , anyway thank you very much for help @hansen

i do change these parameters , but nothing changes , i will try again if i replace the nginx with apache do you think its gonna work correctly ?

@yokotobe i tried every thing about permissions , it does not work !

take a look at destination directory’s write permission


What’s the output of of the following command? If you’ll post this to a code block using the </> icon, that’ll help keep the original formatting.

tail -50 /var/log/nginx/error.log

Looking beyond that, is the Droplet configured identically to your local environment?