Is there an option to turn off the auto append feature when setting up TXT records?

August 17, 2018 985 views
DNS

I’m trying to set up my mail service and I need to enter “mx.domainkey.mg” into the field, but it keeps being appended with “mx.domainkey.mg.WEBSITE_URL”. There doesn’t seem to be any way to disable this feature from what I can tell…

2 Answers

Never mind, I gave up and just used my root domain instead of a sub-domain. I see all kinds of questions online with people having issues with this, yet most of them I notice are never able to get it working correctly with a sub-domain, including me. DO really should make an effort to fix this issue. It’s left a bad taste in my mouth.

  • Did you try entering only “mx”? There is no need to type in the full hostname just the subdomain you are trying to add. :D

    • This is a TXT record. No matter what I type into the field, it gets appended with “.mydomainname.com” on the end. For example if I were to type “mx” into the field, it automatically converts it to “mx.mydomainname.com”. There’s no way to delete the “mydomainname.com” off the end.

      I saw one question where a DO mod suggested to just make a separate domain name, like “mg.mail_server.com”, the problem is that per my mail servers support, one of the TXT records just needs to read “mg”. DO won’t let me make a domain called “mg” because it’s not a valid domain name.

      TLDR their auto append feature seems to be causing all sorts of issues and it is making the process confusing and overly complicated. There should at least be a feature to disable it.

    • Well I had typed up a detailed response, but it got rejected as “spam” and I lost it.

      This is a txt record. Anything you enter into the field gets appended with “.mydomain.com”. So for example, if I were to type “mx” into the field, it automatically gets converted to “mx.mydomain.com”. There’s no way to delete the appended part so that it only reads “mx”.

    • TLDR, I think they added the auto append thing as a convenience feature, but in reality it’s causing a whole lot more inconvenience and frustration that it alleviates. There should at least be an option to disable it.

      • It seems to be the new standard as i’ve seen multiple dns providers do the same. It just takes some getting used to that’s all. :D

        • Get used to not being able to use a sub-domain? I don’t see how it’s possible to get the field to just say “mx._domainkey.mg” on it, with nothing else, which is what my mail service is requiring in order to verify it.
          Anything you type gets appended with “.mydomain.com” and there’s no option to remove it. It’s beyond inconvenient.

          • The “mx._domainkey.mg” would go in the Value field i’m guessing.

          • That’s what I’ve been trying to explain. You can’t just enter “mx.domainkey.mg” into the field. That’s the first thing I tried. It doesn’t work.
            If you type in the letter “a”, it automatically get’s appended to “a.mydomain.com”.
            The very first thing I tried was “mx.
            domainkey.mg” and it automatically got converted to “mx._domainkey.mg.mydomain.com”.
            It’s not possible to simply type something into the field on an TXT record and not have it appended with your domain name. What you’re describing is how they should change it. The fact that what you enter into the field gets converted automatically and there isn’t any way to change it, is causing a bunch of confusion and frustration.
            If you google it, there’s a whole bunch of people having the same issue and a lot of them just gave up, like I did.

Have another answer? Share your knowledge.