joomla install fails after completing the tutorials

  • Posted on March 10, 2014
  • cacjsAsked by cacjs

I have just completed my 2nd attempt at installing Joomla on my droplet both ended in failure at the Joomla installer. Which currently can be seen here

I followed these instructions with one exception I did not add a htaccess file because both time I tried it failed.

#1 Initial Server Setup with Ubuntu 12.04 #2How To Install Linux, Apache, MySQL, PHP (LAMP) stack on Ubuntu #3How To Install Joomla on a Virtual Server Running Ubuntu 12.04

This is a test as I plan to run Joomla 3.0 for production. Any suggestions would be appreciated.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

UPDATE: <br> <br>Something changed at DigitalOcean but I don’t know what it was. <br>I had this site up on 3 different machines running (Firefox,IE,Chrome) all of which had a failed Joomla install screen. All machines had history and cache cleared and retested with the same results also; reload/refresh/ctrl+f5. <br>This morning 03/10/2014 they were all retested and failed and hour later they all worked. <br>I have not been into the server at all so there is no reason for the site to start working. The testing local machines were not cleared of cache or history a simple refresh and they all worked. <br>The only way this could happen is if some one change something on the server and being the only user how can that happen. Hence I say that something or someone at Digital Ocean made a change, I just wish I knew what it was. <br> <br>I’m pulling the Joomla 2.## version and starting again with Joomla 3.0. <br> <br>As a side note the general server set up will not work with Joomla back-end unless ftp is enabled as Joomla uses WebServer to PHP Interface:cgi-fcgi and the general set up uses WebServer to PHP Interface:apache2handler. This causes ownership issues as Joomla does not have ownership to install or backup components, yes files are 755 and 644 but Joomla doesn’t own them and any interaction requiring access to write to the files results in a failure. <br> <br>Is anyone out there willing to write a clean tutorial for Joomla, the one posted now is good, thank you for writing it, but I don’t think it covers ALL the nuances of Joomla. <br> <br>