Question

Mails send from vps go to spam folder in gmail!

  • Posted October 17, 2013

Im hosting a forum on my vps, and the activation emails go to the spam folder, before i had my site hosted in a shared host and this didnt happen, is there anything i can do to fix this? Im using ubuntu 12.04 x64 with zpanel.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, all

You can make sure that your mailing list is fully opted-in and that you’re using SMTP authentication.

Also to test the mail score of your emails you can use a website like:

https://www.mail-tester.com/

and then send a valid test - an exact email with a valid - subject, message body, full signatures and attachments.

Regards, Alex

how to solve about Digital ocean ASN was blocked in ucprotect level 2 and 3? without change IP, because we not want our service down…

50% of digital ocean’s AMS datacenter’s IP’s are blacklisted. That’s why your email are going in to a spam folder in gmail. Stop misinforming people telling them: your spf records or dkim is wrong. It’s just IP’s are blacklisted.

Google might think that your VPS’ security has been compromised. If a script is sending spam from your server, any domain on that server might be considered suspect. Google has been filtering mail from my server to spam recently. I’m looking for solutions to this myself - which is how I found myself here. <br> <br>Best of luck with it.

TXT record name = <code>@</code> <br> <br>RE: MX records, only add Google MX records if you registered your domain with Google Apps.

Im a little lost, i add a new TXT record but what should i put in the fields “Enter Name” and “Enter text”?, is it the domain name in the “Enter Name” and the SPF record in the “Enter text” field? Also in the MX records there is a option to add the gmail MX records should i do that to?

Thanks for the help i’ll try those.

Try creating an SPF record. Check out: <a href=“https://www.digitalocean.com/community/articles/how-to-use-an-spf-record-to-prevent-spoofing-improve-e-mail-reliability”>How To use an SPF Record to Prevent Spoofing & Improve E-mail Reliability</a> and <a href=“http://spfwizard.com/”>easySPF: an Ajax enabled SPF Wizard</a>.

use the force, luke!