My host can't acess to my droplet (where i've mysql db)

Posted July 11, 2017 1.9k views

I’ve a webhost and my BD on a droplet but since my webhost is from my university i cant get acess do my DB.

Already followed some tutorial but until now i still having the same issue over and over again.

Any help?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer


Have you enabled MySQL to listen on the public interface instead of just localhost?
Have you activated firewall on the droplet maybe?
Or could it be that your university has a firewall that blocks access to the database?

  • Yes i’ve tried everything to solve this and nothing worked, i think the problem is with my university firewall and that’s kinda boring …

    • @SNAKJ
      Run this to show listening services:

      sudo lsof -iTCP -sTCP:LISTEN -P

      Run this to show the status of the firewall and list entries:

      sudo ufw status

      And unless you have another external MySQL you can connect to from university, then I’m not sure how to test this yet.