Question

my site is too slow. 8-12 seconds in pingdom test :(

  • Posted on November 22, 2014
  • newbieAsked by newbie

hi, i m having very slow page speed for my site. i have installed w3tc plugin and using cloudflare as CDN but still my page speed is around 8 to 12 second in pingdom pagespeed. i also made speedtest with google pagespeed insight and my site scores 70 for mobile and 88 for desktop which i think fair enough to load a site fast.

but its really loading too slow. is there any issue in DO for singapore servers?

mrcmanager.com is my site address

its on apache with ubuntu 14.04


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Take a look at the following tutorial to speed up your Wordpress site: How To Use WP Super Cache and Jetpack Photon To Optimize WordPress Performance on Ubuntu 14.04 | DigitalOcean. You’ll need to start from scratch and use nginx instead of Apache but that’s not an issue if it’s a fresh install with nothing on it yet.

I did a speedtest of your site on webpagetest to get a complete overview, results - http://www.webpagetest.org/result/141122_QY_0d3a3a9cc5109ed0f4bf4ea609bf887b/

The problem is with too many CSS/JS files loading in the <head> section. First disable Cloudflare and set the IP of the Droplet as the A record.

Before you do any of the following backup your website’s files and its MySQL database.

Go to WP-Admin > Performance > Minify and uncheck Enable in the JS section. Then go to WP-Admin > Performance > General Settings and enable Minify in Auto mode.

Save the settings and check if the frontend loads properly. Then do a speedtest.