Question

My Website not showing SSL Green Bar in the URL

I have installed an SSL certificate on my WordPress website. The https url of my website is working, but it is not shown in green colour. when I click on the top icon in chrome, it shows “your connection to this file is not fully secure”.

However, the green bar comes when I go to the admin panel of my WordPress website.

What am I doing wrong?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I Solved the issue.

The problem is that some URL on my website were still using http:// so, I manually changed all of them to https:// and it worked :)

@GeekNaveen

Under Settings -> General, have you set the WordPress Address and Site Address to the same URL?

Generally, the green lock will only show if everything is secure, so if it’s not, something isn’t using SSL on the page(s) you’re viewing. It could be a JS script, a CSS file, an image, etc.