Question

Need Help: Domain or a subdomain is already owned by another user

Hi DO,

I have a DO account and have been enjoying the great features of DO for around a year. I moved the hosting of my church domain to DO, with a new domain. I also need to setup a mail server with DO.

However, due to a certain misconfig, the domain is added to the mail server instead of the website server droplet instead.

I have deleted the domain from the mail server droplet, but I cannot add it to the web server. It returns “Domain or a subdomain is already owned by another user”

I have submitted a ticket with ID #3249965.

We need to have the website and mail server ready before next Sunday, hence the urgency.

Can someone from DO please help me with this case?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

The system performs a DNS lookup to see if the domain has already been added to DigitalOcean. If it has, you’ll receive a message that says Data domain example.com: Name already exists. If the domain has not been previously added to DigitalOcean’s DNS service, it will be added.

In our public community, we aim to answer open questions about anything SysAdmin, DigitalOcean and beyond. However, we make every attempt to keep personal information safe and so don’t ever access personal account information here. This means we can’t provide help with any account or billing-related issues.

Please reach out to our amazing support team who will be more than happy to assist you with your account issue

https://www.digitalocean.com/support/

Hope that helps!

Hi @dothebest1,

Can you confirmed you had pointed the domain to your Droplet from your Control Panel rather than adding the domain to your Vhost file on the Droplet?

If that’s the case, just adding a new record should help resolve your problem. You’ll need to add an A record for your domain.com and www.domain.com to the droplet where your website is being held. As for the Mail Droplet, you’ll need to add an MX record for your domain.com pointing to the mail droplet.

If you are having issues adding them to the Droplet, please do let us know what WebService you are using on your Website droplet.

Regards, KDSys