Nginx not serving static files despite various configurations

October 3, 2019 1.9k views
Nginx Django

I am trying to deploy my very first site and using django + nginx + gunicorn configuration as instructed in this guide:

However despite doing everything according to instructions my static files are not server. I tried various solutions and read all related questions I can found but with no results. Please help me find an error, tell me way to debug it or just offer an alternative to nginx because it drives me crazy.

My current

STATIC_URL = '/static/'
STATIC_ROOT = '/opt/myenv/static/'
STATICFILES_DIRS = ( '/opt/myenv/static/',)
MEDIA_URL = '/media/'

My ngnix.config:

        server {
                access_log /opt/myenv/STV_skaiciuokle/access.log;
                error_log /opt/myenv/STV_skaiciuokle/error.log warn;

                location /static {
                        autoindex on;
                        alias /opt/myenv/static/;

                location /media {
                        autoindex off;
                        root /opt/myenv/STV_skaiciuokle/skaiciuokle_web/media;

                location / {
                        proxy_set_header X-Forwarded_Host $server_name;
                        proxy_set_header X-Real_IP $remote_addr;
                        add_header P3P 'CP="ALL DSP COR PSAa PSDa OUR NOR ONL UNI COM NAV"';

My static files after collectstatic command are in subfolders named css; img; js in parent folder /opt/myenv/static. For testing purposes I also copied main css file to parent folder. But despite various combinations I tried I got no result.

My related question (with currently no answer in stackowerflow):

P.S. I am sorry for not using format, but for some reason format buttons are un-clickable to me.

edited by bobbyiliev
1 Answer


It looks like that your static files are served just as expected:

The problem that I’m seeing is with your proxy_pass and your backend. You need to make sure that your backend service is actually listening on port 8001. You can do that with:

sudo netstat -plant | grep 8001

If you don’t see any output you need to make sure that you’ve followed the instructions in step 9 regarding the Gunicorn configuration.

Hope that this helps!

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!