Question

No internet connection after command poweroff in Ubuntu 18.04 LAMP server

Posted March 28, 2020 1.3k views
NetworkingUbuntu 18.04

I don’t know why it happened . I just rebooted my droplet in order to make some maintenance and now no internet connection.

I have a message which says network is unrecheable when I ping 8.8.8.8 and if I perform sudo apt-update all mirrors.digitalocean.com fail saying temporary failured couldn’t resolve ....

I have 2 droplets so I tried to copy /etc/resolv.conf nameserver value to my current failing droplet but also didn’t work.

I don’t know what to do and digitalocean takes very much time to answer me.

Already have opened support ticket and none status changed.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @randomspider

What happens when you execute ifconfig -a can you see the eth0 interface listed? If this one is not present then we will need to sort this out.

I know that sometimes some packages can be uninstalled somehow on reboot and there are cases where cloud-init is one of them. You can check if the package is present and currently installed on your droplet as well.

A similar issue was reported here as well: https://www.digitalocean.com/community/questions/no-internet-connection-after-droplet-reboot

You can check the answer posted from lukasea17033bb7e7ecf80fc21 and see the suggested steps if needed.

  1. Create the /etc/udev/rules.d/70-persistent-net.rules file
  2. Reboot tje server
  3. Set the network interface using the information from the /etc/netplan/50-cloud-init.yaml file
  4. Set the routing
  5. Configure the dns resolver conf file (you can skip this if your resolv conf is still present, I know you’ve mentioned that you’ve already copied this from a working droplet)
  6. You can run apt update and apt upgrade
  7. Install cloud-init if it’s missing

Also have you tried to power off the droplet and then start it again instead of just rebooting it? You can perform this action from the control panel.

Let me know how it goes.

Regards,
Alex

  • Hi Alex thanks for supporting me with this valuable info. I folllowed steps provided and now I am able to read packages because internet connection available now. I’m not sure if after I reboot maybe it will be off again, but at least I am installing basic packages such as cloud-init.

    I’ll tell you more as soon as I reboot it

    Thank you very much again

Submit an Answer