Non www URL not working for wordpress

September 3, 2016 1.3k views
WordPress One-Click Install Apps Ubuntu

I am setting up a website on Digital Ocean using the one click install option. Site works fine, but I am facing 2 issues.

  1. The non www url is not working at all.
  2. When I try fetching it as google inside the search console, it says temporary unreachable.

Can anyone suggest me on how to proceed further? The URL is www.indiacityblog.com

Thanks in advance

1 Answer

This is probably because you haven't configured your DNS settings properly. Please make a screenshot or output your current DNS records of this domain and I could help you out.

  • You mean my DNS at godaddy or DigitalOcean??

  • Records at Godaddy:

     A record
    @   104.236.85.248  600 seconds   
    

    CNAME records
    cpanel @ 1 Hour

    ftp @ 1 Hour

    imap imap.secureserver.net 1 Hour

    webdisk @ 1 Hour

    webdisk.admin @ 1 Hour

    whm @ 1 Hour

    www @ 1 Hour

    Zonfile at Digital Ocean

    $ORIGIN www.indiacityblog.com.
    $TTL 1800
    www.indiacityblog.com. IN SOA ns1.digitalocean.com. hostmaster.www.indiacityblog.com. 1472995743 10800 3600 604800 1800

    • This could not be a case, but however I would try even this, just to be sure it's not root of problem...

      As far as I see you added domain with www in DigitalOcean DNS settings.
      Do the following:

      • Login to DigitalOcean Cloud panel
      • Go to Networking
      • Check if your domain is indiacityblog.com or www.indiacityblog.com

      If your domain is www.indiacityblog.com do the following:

      • Open it and write down settings
      • Return to Networking
      • Click on more on right side of www.indiacityblog.com
      • Click Delete and confirm it if needed
      • Add domain but this time DON'T include www (e.g. write ONLY indiacityblog.com)
      • Config it as you wish

      If it is not the case, we can try something other

Have another answer? Share your knowledge.