Question

Not able to access MySQL, not via Virtualmin or SSH. Tried everything.

Using Ubuntu WordPress on 14.04.

I installed Virtualmin and it says ‘‘MySQL does not appear to be installed and running on your system, or has not yet been set up properly in Webmin’s MySQL Database module. If your system does not use MySQL, it should be disabled in Virtualmin’s module configuration page’’.

**When I go to the MySQL Database module, it does not let me log in with any user and password combinations, I’ve changed them from the module’s configuration, from the system’s configuration, I’ve tried everything via SSH, yet it does still not let me log in and gives the following error: ** Login failed : Incorrect administration username or password

**and the error via SSH is: **ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

Doesn’t matter if I try a password or not, the outcome is the same.

I’ve literally tried everything I could find on the internet about this issue and nothing seems to fix my problem. Help very much needed.

Does anyone have any ideas? Thank you in advance.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Does not work. /etc/init.d/mysql does not exist.

Hi!

Try resetting MySQL’s root password and then configuring Virtualmin’s MySQL module in its module configuration page as the error suggests.