Question

Openvpn setup on ubuntu

Connected Tutorial
This question is a follow-up to this tutorial:

Hello. Followed the tutorial for setting up openvpn on ubuntu 20.04. I got it mostly up and running but when I connect I can’t browse and effectively have no internet access. However I can ONLY load 1.1.1.1 web page, and I can ping anything on the internet and can do nslookups and ping urls. I am also able to maintain my SSH session to the server. I’ve spent over 2 months on this so far and have redone the tutorial multiple times with no changes. Is there some setting I’m missing or the tutorial skipped over?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there

I’ve just setup a new droplet and followed the tutorial and managed get it up and running. I haven’t noticed any issues so far.

I’ve also spin up a droplet using the one click install for the OpenVPN Access Server and everything is working normal:

https://marketplace.digitalocean.com/apps/openvpn-access-server

Are you following the article on fresh droplet or you’ve installed everything on existing droplet that is used for some other purposes as well? I will recommend you to follow the steps on a fresh droplet or try the one-click install application from the marketplace.

Let me know how it goes. Regards, Alex