Question

/phpmyadmin stopped working after I changed PHP from 8.0 to 7.4

Posted May 15, 2021 112 views
CentOS

I used this tutorial to change the version of my PHP
https://www.linuxhelp.com/how-to-upgrade-and-downgrade-the-php-versions-on-centos-7-6

so far so good, everything worked just fine, but when I needed to enter phpmyadmin, I noticed that I couldn’t access it anymore

And when I try to install the following message again:

[root@Testando yum.repos.d]# yum -y install phpmyadmin
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: sjc.edge.kernel.org
 * epel: sjc.edge.kernel.org
 * extras: mirror.sfo12.us.leaseweb.net
 * remi: mirror.bebout.net
 * remi-php55: mirror.bebout.net
 * remi-php56: mirror.bebout.net
 * remi-safe: mirror.bebout.net
 * remi-test: mirror.bebout.net
 * updates: sjc.edge.kernel.org
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:5.1.0-3.el7.remi will be installed
--> Processing Dependency: php-google-recaptcha >= 1.1 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-nikic-fast-route >= 1.3 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-phpmyadmin-motranslator5 >= 5.0 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-phpmyadmin-shapefile >= 2.0 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-phpseclib >= 2.0.9 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-pragmarx-google2fa-qrcode >= 1.0.1 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-samyoul-u2f-php-server >= 1.1 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-symfony-polyfill >= 1.17 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-symfony4-config >= 4.4.9 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-symfony4-dependency-injection >= 4.4.9 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-symfony4-expression-language >= 4.4.9 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-tcpdf >= 6.3 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts >= 6.2 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-twig2 >= 2.9 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-williamdes-mariadb-mysql-kbs >= 1.2 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-composer(fedora/autoloader) for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-phpmyadmin-sql-parser5 for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-phpmyadmin-twig-i18n-extension for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-simplexml for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-xml for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-xmlwriter for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Processing Dependency: php-zip for package: phpMyAdmin-5.1.0-3.el7.remi.noarch
--> Running transaction check
---> Package php-fedora-autoloader.noarch 0:1.0.1-2.el7.remi will be installed
---> Package php-google-recaptcha.noarch 0:1.2.4-1.el7.remi will be installed
---> Package php-nikic-fast-route.noarch 0:1.3.0-6.el7.remi will be installed
---> Package php-pecl-zip.x86_64 0:1.19.2-1.el7.remi.5.6 will be installed
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
---> Package php-phpmyadmin-motranslator5.noarch 0:5.2.0-1.el7.remi will be installed
---> Package php-phpmyadmin-shapefile.noarch 0:2.1-1.el7.remi will be installed
---> Package php-phpmyadmin-sql-parser5.noarch 0:5.4.2-1.el7.remi will be installed
---> Package php-phpmyadmin-twig-i18n-extension.noarch 0:3.0.0-1.el7.remi will be installed
---> Package php-phpseclib.noarch 0:2.0.31-1.el7.remi will be installed
--> Processing Dependency: php-bcmath for package: php-phpseclib-2.0.31-1.el7.remi.noarch
--> Processing Dependency: php-gmp for package: php-phpseclib-2.0.31-1.el7.remi.noarch
---> Package php-pragmarx-google2fa-qrcode.noarch 0:1.0.3-1.el7.remi will be installed
--> Processing Dependency: php-bacon-qr-code for package: php-pragmarx-google2fa-qrcode-1.0.3-1.el7.remi.noarch
--> Processing Dependency: php-pragmarx-google2fa5 for package: php-pragmarx-google2fa-qrcode-1.0.3-1.el7.remi.noarch
---> Package php-samyoul-u2f-php-server.noarch 0:1.1.4-1.el7.remi will be installed
---> Package php-symfony-polyfill.noarch 0:1.22.1-1.el7.remi will be installed
--> Processing Dependency: php-intl for package: php-symfony-polyfill-1.22.1-1.el7.remi.noarch
---> Package php-symfony4-config.noarch 0:4.4.22-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/filesystem) = 4.4.22 for package: php-symfony4-config-4.4.22-1.el7.remi.noarch
---> Package php-symfony4-dependency-injection.noarch 0:4.4.22-1.el7.remi will be installed
--> Processing Dependency: php-symfony4-common = 4.4.22-1.el7.remi for package: php-symfony4-dependency-injection-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/container) < 2.0 for package: php-symfony4-dependency-injection-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(symfony/service-contracts) < 2 for package: php-symfony4-dependency-injection-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/container) >= 1.0 for package: php-symfony4-dependency-injection-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(symfony/service-contracts) >= 1.1.10 for package: php-symfony4-dependency-injection-4.4.22-1.el7.remi.noarch
---> Package php-symfony4-expression-language.noarch 0:4.4.22-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/cache) = 4.4.22 for package: php-symfony4-expression-language-4.4.22-1.el7.remi.noarch
---> Package php-tcpdf.noarch 0:6.4.1-2.el7.remi will be installed
--> Processing Dependency: php-posix for package: php-tcpdf-6.4.1-2.el7.remi.noarch
--> Processing Dependency: php-tidy for package: php-tcpdf-6.4.1-2.el7.remi.noarch
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.4.1-2.el7.remi will be installed
---> Package php-twig2.noarch 0:2.14.5-1.el7.remi will be installed
---> Package php-williamdes-mariadb-mysql-kbs.noarch 0:1.2.12-1.el7.remi will be installed
---> Package php-xml.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-xml-5.6.40-26.el7.remi.x86_64
--> Running transaction check
---> Package php-bacon-qr-code.noarch 0:1.0.3-1.el7.remi will be installed
---> Package php-bcmath.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-bcmath-5.6.40-26.el7.remi.x86_64
---> Package php-gmp.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-gmp-5.6.40-26.el7.remi.x86_64
---> Package php-intl.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-intl-5.6.40-26.el7.remi.x86_64
---> Package php-pecl-zip.x86_64 0:1.19.2-1.el7.remi.5.6 will be installed
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
---> Package php-pragmarx-google2fa5.noarch 0:5.0.0-1.el7.remi will be installed
--> Processing Dependency: php-paragonie-constant-time-encoding for package: php-pragmarx-google2fa5-5.0.0-1.el7.remi.noarch
--> Processing Dependency: php-paragonie-random-compat for package: php-pragmarx-google2fa5-5.0.0-1.el7.remi.noarch
---> Package php-process.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-process-5.6.40-26.el7.remi.x86_64
---> Package php-psr-container.noarch 0:1.1.1-1.el7.remi will be installed
---> Package php-symfony-contracts.noarch 0:1.1.10-1.el7.remi will be installed
--> Processing Dependency: php-psr-cache for package: php-symfony-contracts-1.1.10-1.el7.remi.noarch
--> Processing Dependency: php-psr-event-dispatcher for package: php-symfony-contracts-1.1.10-1.el7.remi.noarch
---> Package php-symfony4-cache.noarch 0:4.4.22-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/var-exporter) = 4.4.22 for package: php-symfony4-cache-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/log) < 2.0 for package: php-symfony4-cache-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/simple-cache) < 2.0 for package: php-symfony4-cache-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/log) >= 1.0 for package: php-symfony4-cache-4.4.22-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/simple-cache) >= 1.0 for package: php-symfony4-cache-4.4.22-1.el7.remi.noarch
---> Package php-symfony4-common.noarch 0:4.4.22-1.el7.remi will be installed
--> Processing Dependency: composer for package: php-symfony4-common-4.4.22-1.el7.remi.noarch
---> Package php-symfony4-filesystem.noarch 0:4.4.22-1.el7.remi will be installed
---> Package php-tidy.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-tidy-5.6.40-26.el7.remi.x86_64
---> Package php-xml.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-xml-5.6.40-26.el7.remi.x86_64
--> Running transaction check
---> Package composer.noarch 0:2.0.13-1.el7.remi will be installed
--> Processing Dependency: php-composer-spdx-licenses >= 1.2 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-composer-xdebug-handler >= 1.1 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-jsonlint >= 1.4 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-justinrainbow-json-schema5 >= 5.2.10 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-react-promise >= 2.7 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-seld-phar-utils >= 1.1 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-symfony3-console >= 3.4.35 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-symfony3-filesystem >= 3.4.35 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-symfony3-finder >= 3.4.35 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-symfony3-process >= 3.4.35 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-composer-ca-bundle for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-composer-metadata-minifier for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-composer-semver3 for package: composer-2.0.13-1.el7.remi.noarch
--> Processing Dependency: php-seld-phar-utils for package: composer-2.0.13-1.el7.remi.noarch
---> Package php-PsrLog.noarch 0:1.1.4-1.el7.remi will be installed
---> Package php-bcmath.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-bcmath-5.6.40-26.el7.remi.x86_64
---> Package php-gmp.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-gmp-5.6.40-26.el7.remi.x86_64
---> Package php-intl.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-intl-5.6.40-26.el7.remi.x86_64
---> Package php-paragonie-constant-time-encoding.noarch 0:2.4.0-1.el7.remi will be installed
---> Package php-paragonie-random-compat.noarch 0:2.0.18-1.el7.remi will be installed
---> Package php-pecl-zip.x86_64 0:1.19.2-1.el7.remi.5.6 will be installed
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
---> Package php-process.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-process-5.6.40-26.el7.remi.x86_64
---> Package php-psr-cache.noarch 0:1.0.1-3.el7.remi will be installed
---> Package php-psr-event-dispatcher.noarch 0:1.0.0-2.el7.remi will be installed
---> Package php-psr-simple-cache.noarch 0:1.0.1-1.el7.remi will be installed
---> Package php-symfony4-var-exporter.noarch 0:4.4.22-1.el7.remi will be installed
---> Package php-tidy.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-tidy-5.6.40-26.el7.remi.x86_64
---> Package php-xml.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-xml-5.6.40-26.el7.remi.x86_64
--> Running transaction check
---> Package php-bcmath.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-bcmath-5.6.40-26.el7.remi.x86_64
---> Package php-composer-ca-bundle.noarch 0:1.2.9-1.el7.remi will be installed
---> Package php-composer-metadata-minifier.noarch 0:1.0.0-1.el7.remi will be installed
---> Package php-composer-semver3.noarch 0:3.2.4-1.el7.remi will be installed
---> Package php-composer-spdx-licenses.noarch 0:1.5.5-1.el7.remi will be installed
---> Package php-composer-xdebug-handler.noarch 0:1.4.6-1.el7.remi will be installed
---> Package php-gmp.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-gmp-5.6.40-26.el7.remi.x86_64
---> Package php-intl.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-intl-5.6.40-26.el7.remi.x86_64
---> Package php-jsonlint.noarch 0:1.8.3-1.el7.remi will be installed
---> Package php-justinrainbow-json-schema5.noarch 0:5.2.10-1.el7.remi will be installed
---> Package php-pecl-zip.x86_64 0:1.19.2-1.el7.remi.5.6 will be installed
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
---> Package php-process.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-process-5.6.40-26.el7.remi.x86_64
---> Package php-react-promise.noarch 0:2.8.0-1.el7.remi will be installed
---> Package php-seld-phar-utils.noarch 0:1.1.1-1.el7.remi will be installed
---> Package php-symfony3-console.noarch 0:3.4.47-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/debug) = 3.4.47 for package: php-symfony3-console-3.4.47-1.el7.remi.noarch
---> Package php-symfony3-filesystem.noarch 0:3.4.47-1.el7.remi will be installed
--> Processing Dependency: php-symfony3-common = 3.4.47-1.el7.remi for package: php-symfony3-filesystem-3.4.47-1.el7.remi.noarch
---> Package php-symfony3-finder.noarch 0:3.4.47-1.el7.remi will be installed
---> Package php-symfony3-process.noarch 0:3.4.47-1.el7.remi will be installed
---> Package php-tidy.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-tidy-5.6.40-26.el7.remi.x86_64
---> Package php-xml.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-xml-5.6.40-26.el7.remi.x86_64
--> Running transaction check
---> Package php-bcmath.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-bcmath-5.6.40-26.el7.remi.x86_64
---> Package php-gmp.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-gmp-5.6.40-26.el7.remi.x86_64
---> Package php-intl.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-intl-5.6.40-26.el7.remi.x86_64
---> Package php-pecl-zip.x86_64 0:1.19.2-1.el7.remi.5.6 will be installed
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64
---> Package php-process.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-process-5.6.40-26.el7.remi.x86_64
---> Package php-symfony3-common.noarch 0:3.4.47-1.el7.remi will be installed
---> Package php-symfony3-debug.noarch 0:3.4.47-1.el7.remi will be installed
---> Package php-tidy.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-tidy-5.6.40-26.el7.remi.x86_64
---> Package php-xml.x86_64 0:5.6.40-26.el7.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.40-26.el7.remi for package: php-xml-5.6.40-26.el7.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-xml-5.6.40-26.el7.remi.x86_64 (remi-php56)
           Requires: php-common(x86-64) = 5.6.40-26.el7.remi
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.19-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-18.el7.remi
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-11.el7.remi
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-12.el7.remi
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-25.el7.remi
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-26.el7.remi
Error: Package: php-gmp-5.6.40-26.el7.remi.x86_64 (remi-php56)
           Requires: php-common(x86-64) = 5.6.40-26.el7.remi
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.19-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-18.el7.remi
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-11.el7.remi
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-12.el7.remi
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-25.el7.remi
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-26.el7.remi
Error: Package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64 (remi-php56)
           Requires: php(zend-abi) = 20131226-64
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php(zend-abi) = 20190902-64
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php(zend-abi) = 20100525-64
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php(zend-abi) = 20100525-64
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php(zend-abi) = 20131226-64
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php(zend-abi) = 20131226-64
Error: Package: php-intl-5.6.40-26.el7.remi.x86_64 (remi-php56)
           Requires: php-common(x86-64) = 5.6.40-26.el7.remi
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.19-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-18.el7.remi
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-11.el7.remi
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-12.el7.remi
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-25.el7.remi
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-26.el7.remi
Error: Package: php-process-5.6.40-26.el7.remi.x86_64 (remi-php56)
           Requires: php-common(x86-64) = 5.6.40-26.el7.remi
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.19-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-18.el7.remi
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-11.el7.remi
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-12.el7.remi
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-25.el7.remi
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-26.el7.remi
Error: Package: php-tidy-5.6.40-26.el7.remi.x86_64 (remi-php56)
           Requires: php-common(x86-64) = 5.6.40-26.el7.remi
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.19-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-18.el7.remi
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-11.el7.remi
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-12.el7.remi
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-25.el7.remi
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-26.el7.remi
Error: Package: php-pecl-zip-1.19.2-1.el7.remi.5.6.x86_64 (remi-php56)
           Requires: php(api) = 20131106-64
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php(api) = 20190902-64
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php(api) = 20100412-64
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php(api) = 20100412-64
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php(api) = 20131106-64
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php(api) = 20131106-64
Error: Package: php-bcmath-5.6.40-26.el7.remi.x86_64 (remi-php56)
           Requires: php-common(x86-64) = 5.6.40-26.el7.remi
           Installed: php-common-7.4.19-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.19-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
           Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-18.el7.remi
           Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-11.el7.remi
           Available: php-common-5.5.38-12.el7.remi.x86_64 (remi-php55)
               php-common(x86-64) = 5.5.38-12.el7.remi
           Available: php-common-5.6.40-25.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-25.el7.remi
           Available: php-common-5.6.40-26.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-26.el7.remi
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

already tried to install using:

yum --enablerepo=remi install phpMyAdmin

or:

yum install -y –enablerepo=remi-php56 phpmyadmin

The /usr/share/phpMyAdmin folder does not exist

Everything works normal, the site, php, mysql (mariaDb), the only thing that doesn’t work is phpmyadmin

I’ve been trying to solve it for many days and I’ve tried several solutions spread over the web, I don’t know what else to do.

Use centos 7 with VestaCP panel and PHP 7.4

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

I was giving some bug in relation to a “Dependency”

I listened to the following codes, and mysteriously it worked for me, and everything went back to normal:

yum install yum-utils -y

yum remove php* -y

yum --disablerepo=remi-php73 --enablerepo=remi-php71 install php php-gd php-mbstring php-mysql php-curl php-mcrypt

yum-config-manager --enable remi-php74

yum install php-zip -y

php -v

yum install phpMyAdmin -y

nano /etc/httpd/conf.d/phpMyAdmin.conf

Then edit the “/etc/httpd/conf.d/phpMyAdmin.conf” file like this:

<Directory /usr/share/phpMyAdmin/>
   Order Deny,Allow
   Deny from All
   Allow from All
</Directory>

<Directory /usr/share/phpMyAdmin/scripts/>
   Order Deny,Allow
   Deny from All
   Allow from All
</Directory>

And finally restart apache

service httpd restart

Try to uninstall phpmyadmin first, then purge it (I’m more of Ubuntu/Debian guy with apt experience) to any remnants are removed, then try to install it again.

Hope it helps.

  • I uninstalled, the problem was time to install again
    After a long time breaking my head I found the solution and posted it as an answer