Question

Pi-hole and OpenVPN - Step 4 — Testing DNS Filtering - dosen't work

Posted May 13, 2021 119 views
Ubuntu 16.04

As I was following this tutorial — https://www.digitalocean.com/community/tutorials/how-to-block-advertisements-at-the-dns-level-using-pi-hole-and-openvpn-on-ubuntu-16-04#step-1-%E2%80%94-gathering-network-information

At Step 4 Testing DNS Filtering - I run “host pagead2.googlesyndication.com 10.8.0.1” but I got the following as here.

root@openvpn-pihole:~/Pi-hole/automated install# host pagead2.googlesyndication.com 10.8.0.1
Using domain server:
Name: 10.8.0.1
Address: 10.8.0.1#53
Aliases:

pagead2.googlesyndication.com has address 0.0.0.0
pagead2.googlesyndication.com has IPv6 address ::
pagead2.googlesyndication.com has address 0.0.0.0

As you see there is no my default gateway address in the output 10.8.0.1.

What wrong with my setup?

Many thanks in advance.

Salai

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hello, @salai

Have you chosen the recommended settings/options in the article or you’re using custom ones?

Also, can you share the exact server specs that you’re running that installer on?

Keep in mind that there is an PiHole + OpenVPN droplet available in our marketplace which you can check here:

https://marketplace.digitalocean.com/apps/openvpn-pihole

Regards,
Alex

  • Hello Alex,

    Thanks.

    I carefully did the recommended settings/options as in that article. I did 4 times ( 4 x create droplet). The results was the same.

    Regards,
    Salai

    • Hello,

      Have you tried running the installer on a newer Ubuntu version or you’ve tried to configure it only on Ubuntu 16.04?

      Regards,
      Alex

      • Hi Alex,

        I try on latest Ubuntu and not as in article Ubuntu 16.04. Is there a lot different for settings?

        Best Regards,
        Salai

        • Hello,

          It should be okay to run this on newer Ubuntu versions as well. I’ve tested this on my side on a fresh Ubuntu 18.04 droplet and everything works as expected. This also works as a charm on a Raspberry Pi.

          Did you configure the Pi-Hole on a fresh droplet or you’re doing this on a droplet that is being used for something else as well?

          Regards,
          Alex