Question

Received no credentials after creating droplet.

Posted June 4, 2020 101 views
DigitalOcean

Hi digitalocean team,

I’m new here with the intension of trying it out for future references. I created several droplets but did not receive credentials for it. Upon creating account and making payments, I received email confirmations for the payment and also for DigitalOcean credit, but the mail for the credentials never came in.

Kindly rectify/advise on this problem, as it is for an urgent application that needs to be reviewed very soon.

Regards
Gabriel

NOTE: I have added the support@support.digitalocean.com to my mailbox whitelist, even after receiving two separate mails from same address.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @larneygee

In our public community, we aim to answer open questions about anything SysAdmin, DigitalOcean and beyond. However, we make every attempt to keep personal information safe and so don’t ever access personal account information here. This means we can’t provide help with any account or billing-related issues.

You will receive an email with the droplet’s details shortly after the server has been deployed. The sender email address is the one you’ve mentioned so this should be delivered to your INBOX, however you can still check if the mail filter is configured properly.

If you’re still not receiving the emails, you can contact our amazing support team and they will check this for you.

https://www.digitalocean.com/support/

Hope this helps!

Regards,
Alex

Submit an Answer