SFtp refuse connection

H all guys

I’m newbie to do , i tried to connect through sftp but connection refused ,

I have googled for 2 dys , get annoyed

I tried installing vsftpd , is it required or not !?

But also it doesn’t work ??

Itried connect from phpstorm , other ftp client … I got Connection refused

I added 2 more users than root … the same problem?

My droplet contains ubuntu16.04 apache nginx php composer laravel .

Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi @lifesound

Did you setup your Droplet with keys or did you get a root password?

You don’t need to install anything or setup anything, since SFTP is supported by SSH, which is installed by default on your Droplet. As long as you can connect thru SSH to your server, then you can SFTP. Unless you’ve changed the configuration of /etc/ssh/sshd_config.

And to create new users, have a look in this tutorial:

SFTP uses port 22, not port 21.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

For anyone facing problems , go directly to Filezilla