Question

Showing IP address in Address bar and not Domain Name

I just added a domain to my dns settings and added the a, aaaa, cname records but when I type in my domain name, my ip address shows on the address bar instead.

Someone suggested I change the ServerName in /etc/apache2/sites-enabled/000-default.conf, I did but it did not work also. Please someone help me out.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @ryanpq:

Are you by chance running Wordpress? The name changing to the IP generally is something being done by the scripts you are running or an .htaccess redirect. If you are using Wordpress you will need to ensure that in your general settings the site is set up to use the domain and not the IP.

View the original comment