Site isn't available

August 1, 2016 635 views
DNS Nginx Networking Ubuntu Ubuntu 16.04

Hi, I followed this tutorial to configure my domain and DNS records for my site terrallewis.me, https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean and all things seem to line up correctly. It's been over 48 hrs and my site still isn't available using the domain name or ip address . Is there something else that needs to be configured? I'm running Ubuntu with nginx as my server. Is there something i'm missing? Thanks!

4 Answers
JamesTheDev5 August 3, 2016
Accepted Answer

Double check that you have configured your DNS Correctly then use http://mxtoolbox.com/ to ensure that the DNS had propagated (or is propagating) correctly. Then restart NGINX if you believe it could be a problem with the server, and check that you have opened ports 80 (for http) or 443 (for https) to ensure web traffic can be routed through your server.

I'm getting these errors when I use the tool:

Bad Glue Detected
Parent server gave glue for www.terrallewis.me to be terrallewis.me but we resolve that hostname to 45.55.76.82 More Info
At least one name server failed to respond in a timely manner
Failure detail: 45.55.76.82 More Info
Local NS list does not match Parent NS list
198.41.222.173 was reported by the parent, but not locally
173.245.58.51 was reported by the parent, but not locally
173.245.59.41 was reported by the parent, but not locally
45.55.76.82 was reported locally, but not by the parent More Info
SOA Serial Number Format is Invalid
ns3.digitalocean.com reported Serial 1470267834 : Suggested serial format year was 1470 which is before 1970. More Info
SOA Expire Value out of recommended range
ns3.digitalocean.com reported Expire 604800 : Expire is recommended to be between 1209600 and 2419200. More Info
Open Zone Transfer Detected
198.41.222.173
173.245.58.51
173.245.59.41

Found the issue, site is now up. Thanks!

Have another answer? Share your knowledge.