SSH keys don't work on new droplets - docker 1-click image

I have several droplets active with which I can log in via ssh perfectly fine. However, when I create a new droplet with enabled ssh keys, I cannot log in after the droplet is created which makes it quite difficult to get work done.

I’ve tried on both generic Ubuntu installations and the 1-click Docker installation which I was hoping to use. I’ve gone through DO’s ssh debugging protocol and nothing seems to pop up. What’s going on and how can I access the server without needing to disable ssh keys and log in via username/password?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This doesn’t seem to be a common issue. If you’ve tried creating a new ssh key, adding that to your account, and adding that to new Droplets and are still experiencing the same issue, please contact us at and log a ticket (as the account you’re using in the DigitalOcean Control Panel) so we can directly assist you.

I am also facing some time.