SSL not working on server

Posted September 16, 2019 5.9k views
UbuntuDigitalOceanUbuntu 18.04

I am having problems getting SSL going on the server I followed the following instructions here for Apache

and my SSL certificate isn’t working here is my vitutal host configuration

# Added to mitigate CVE-2017-8295 vulnerability
UseCanonicalName On
<VirtualHost *:443>
        ServerAdmin webmaster@localhost

        ServerName $domain
        ServerAlias www.$domain
        Redirect permanent /

        SSLEngine on
        SSLCACertificateFile      /etc/ssl/certs/4f48e133ed38192c.crt
        SSLCertificateKeyFile  /root/

        DocumentRoot /var/www/html

        <Directory /var/www/html/>
            Options FollowSymLinks
            AllowOverride All
            Require all granted

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers


I believe that Apache might not have access to the /root/ directory. So Apache is failing to read the key.

I would recommend moving your key to /etc/ssl/ for example and then testing this again.

Let me know how it goes!

This is what the issue was. You need to be in the following folder when a new droplet is created.