Question

Trouble with HTTPS

As I deployed my React app, I ran into an issue regarding head access denied, so I just added the DANGEROUSLY_DISABLE_HOST_CHECK=true env variable. But when I added my custom domain (which don’t has a SSL certificate) it became a blank page when accessed through the domain, and works fine with the DigitalOcean default url. I think the problem is in the SSL certificate, so I’m looking for help on disabling it…


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

Do you see any errors in your web console? Usually, this could happen when your static resources are being loaded via HTTPS but you’ve accessed your website via HTTP, this results in mixed content and the browser would not load the resources.

Two possible solutions:

  • Enable an SSL certificate so that the site loads fine via HTTPS. You could do that by pointing your Nameservers to the Cloudflare nameservers and using their free certificate.

  • Change your app so that it loads all resources via HTTP rather than HTTPS.

Hope that this helps.

Best,

Bobby