Trouble with Initial Server Setup

  • Posted April 12, 2013

Hey there,

I followed this guide -

  • to step 6, and then when I opened a new terminal window and tried to ssh in using the user I’d made and to whom I’d granted access, it gave me a ‘Bad Port’ error.

I went back in with the first terminal instance and reverted everything to its original state, but then when I tried to ssh in using either root or my new user, it gave me:

ssh: connect to host port 22: Operation timed out

And now it also gives me:

ssh: connect to host port 22: Connection refused

I’m also trying to access my server through the DigitalOcean control panel console and it isn’t working - it says that it connects but it just comes up with a black screen.

Could you please help with this?

Gratefully, Shane


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

In the guide we provide if you notice you are updating your sshd_config which is moving the default SSH port from port 22 to port Port 25000. <br> <br>So you would need to now do: <br> <br>ssh user@xx.xx.xx.xx -p 25000

I received my ip, followed by: port 22 (tcp) failed: Connection timed out

Do you have configure any firewall software on your droplet? <br> <br>Connection refused error probably your droplet closed tcp 22 port <br> <br>type your console <br> <br>nc -vvn youripaddress 22 <br> <br>if you recive connection refused your port closed <br> <br>if you never connect your droplet try to web console access <br> <br>" <br>Web Console Access <br> <br>If you ever get locked out of your virtual server, you’ll be able to recover it with full console access. HTML5 enabled so you can use it on any device. Bad kernel, wrong iptables rule - no problem. <br>" <br> <br>

Do you know why I can’t connect using my own terminal?

The blank screen can be connected to by clicking on it and pressing any key.

OH, and I’m using the most recent version of OSX, if that makes a difference.