Trying to launch recovery console by changing root password, but unable to.

Iam unable to access m droplet console. So, I tried the launch recovery console. Since I didnt remember my root password, I tried ‘Reset Root password’. I got an email about my temporary password. When I tried to login with this temporary password, it prompted to change the password. I entered the current password, new password ( twice ) as prompted. Then it took me to the login screen and I entered my new password. However, it is not letting me in. I am unable to login to my droplet. Please help.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
September 6, 2022

Hello @neelimakaralgikar

Can you access the droplet with a normal ssh-client and use the new password for the root user?

When you log in to the Droplet with your new password via SSH, the operating system will ask you to change the password. It will first ask for the current password (the new root password emailed to you), and then ask you to enter the new password twice.


Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up