Ubuntu 14.04 + VestaCP: Branded nameservers issue.

April 14, 2016 802 views
DNS

Hello guys, how are you?

I need a little help asap. I'm using vestacp on ubuntu 14.04 at digitalocean. I'm trying trying to set up my branded nameservers with success following the VestaCP Documentation. Can you see my step by step below and tell me what i'm doing wrong?

My domain is cmt.rocks, and my vps ip is 162.243.228.89.

1) First of all I'm going to my domain registrar, the namecheap and registering the glue records:

https://s30.postimg.org/8krfma3sd/Screenshot+from+2016-04-14+02:05:41.png

I'm pointing both the NS1 and NS2 to the digitalocean droplet IP which is 162.243.228.89.

2) Now i've changed the domains namesevers to ns1.cmt.rocks and ns2.cmt.rocks.

https://s28.postimg.org/frld0v1o9/Screenshot+from+2016-04-14+02:08:33.png

3) Now on VestaCP, i added my domain cmt.rocks.

https://s28.postimg.org/6y7f9q5xl/Screenshot+from+2016-04-14+02:10:50.png

4) Than, on DNS I have changed the template to child-ns and also edited the package, changing the name servers to ns1.cmt.rocks and ns2.cmt.rocks.

https://s9.postimg.org/wr1o1p3cb/Screenshot+from+2016-04-14+02:13:09.png

https://s9.postimg.org/7z21ugm5n/Screenshot+from+2016-04-14+02:13:45.png

5) now in the DNS I pointed a NS1 A to VPS IP, and the same to NS2. See my dns list bellow:

LISTING CMT.ROCKS
@TXT "v=spf1 a mx ip4:162.243.228.89 ?all"
@MX10 mail.cmt.rocks.
ftpA 162.243.228.89
popA 162.243.228.89
wwwA 162.243.228.89
mailA 162.243.228.89
ns2A 162.243.228.89
ns1A 162.243.228.89
@A 162.243.228.89
@NS ns2.cmt.rocks.
@NS ns1.cmt.rocks.


And finally, after a couple hours and still getting that message when trying access the website:

https://s21.postimg.org/wkmyeoarn/Screenshot+from+2016-04-14+02:16:27.png

Does anyone know what I doing wrong or what I'm missing?

1 comment
  • Doing a bit of checking revealed that ns1.cmt.rocks resolves to 198.199.120.125 and not to 162.243.228.89 as you intended. I would check your nameserver registration and make sure it has updated with your registrar.

1 Answer

This question was answered by @ryanpq:

Doing a bit of checking revealed that ns1.cmt.rocks resolves to 198.199.120.125 and not to 162.243.228.89 as you intended. I would check your nameserver registration and make sure it has updated with your registrar.

View the original comment

Have another answer? Share your knowledge.