Unable to login as root or ssh

March 9, 2018 65 views
Linux Commands Ubuntu 16.04

Hi there

I am a bit stuck and not sure how it happened or what to do.

I had an apache2 error, i restarted the server and since then nothing wants to work.

I cannot connect via ssh it immediately says connection closed by IP Port 22.

Using the command through digital ocean wont let me sign in as root at all it says login incorrect without password confirmation.

I am unsure of how to proceed to login.

kind regards

2 Answers

If you are having trouble SSHing into your Droplet, you can use the remote console to access it through the control panel. It is very limited in functionality as it's meant for emergency access, so once you're in, try to resolve the SSH issue (do you have a firewall installed?) and then work through the other issues (apache2) via SSH.

You won't see any feedback when you enter your root password. That's normal, just enter the password and press enter. If you do not know your root password, you can also reset it through the control panel.

Well the issue is i have tried using the console to access it directly, however when i just type root as a username in, i instantly get a login failed. I havent even attempted to type the password in. i reset the password with still no luck.

All that i could do is lucky i have backups running and just restored from the backup, all the new information i will have to recapture but i couldnt wait to somehow fix the problem as the server was completely down.

Have another answer? Share your knowledge.