Question

Urgent: Problem with Categories WordPress Not Working...

When trying to view a category page, such as this one: [http://estranhos.info/category/bizarro] , I either get a 404 error or am redirected to home page or post with a similar name to the category.

How to remove this CATEGORY for menus normally open well: [http://estranhos.info/bizarro]; [http://estranhos.info/ciencia/universo/] etc.

Strangely, categories have worked previously with my blog, and permalinks for entries work just fine.

I disabled several plugins, and she returned to work briefly, but then gets swings. Can anyone help fix this? Thank you very much.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Try:

1). Backup your .htaccess file. 2). Delete your .htaccess file from your web root. 3). Login to the WordPress Dashboard @ /wp-admin/ 4). From the sidebar, navigate to the permalinks section and click save.

Number 4 will generate a fresh .htaccess file with all parameters needed by both WordPress and any plugins that are currently activated.

Any plugins that modify the permalink structure often require that you re-save your permalinks afterwards so that all URI’s are updated.

The second issue, where you’re redirected to similar posts/pages, is common and IIRC, standard with WordPress. It’ll attempt to deliver a post/page similar to the request and when it’s unable to do so, will 404.

I’m not sure if this will work for you, but I tried this after all the other options failed and it worked painlessly for me.

Go to your Wordpress Dashboard, down to settings, click Permalinks.

My permalink option under the Common Settings was set to the “Custom Structure” option, so I simply clicked the “Post Name” permalink option, saved it, refreshed, and now it shows up!

Hope that helps a little.

My issues are not exactly the same as yours, but similar in that they were working fine on shared hosting and then experienced some problems after being transferred to DO.

Shared hosting won’t be configured exactly the same as your DO VPS. In my case, there was errors in the logs, which had to do with PHP scripts failing. These were mostly resolved when I re-updated my plugins.