Question not updating on Django production server , which uses nginx and gunicorn

I am currently hosting a Django Webapp , To run it in production mode I use NGINX and gunicorn.

The Error that I am facing is:

The production server doesnt seem to update, no matter what I do

App used to transfer files from local file to instance : FileZilla

Steps that I have taken trying to solve the issue:

1.Deleting the and rewriting it

2.Checking if other files also refuse to get updated

RESULT of 2nd step: Other files are successfully getting updated, I tested with static files and with index.html

3.Checking if the file is updated in the instance using The nano editor

RESULT of 3rd step: The file is properly updated in the instance, with all changes being reflected

4.Running it on the instance using python runserver (for development purposes), and found out that the is getting updated properly when using runserver

Other Information:

1.Everything was getting updated properly just yesterday, but suddenly it decides to act rebellious

2.I have updated all packages using sudo yum install

3.I have restarted nginx and gunicorn: using commands such as :

sudo systemctl enable gunicorn

sudo systemctl restart nginx```

4.I have tried checking for errors using ```sudo nginx -t```, but no errors show up

5.I've checked the error logs, using ```sudo tail -f /var/log/nginx/error.log``` , but no errors show
up here either

How do I solve this?

Thank you
Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Ok so I found the solution.

Steps taken to solve it:

  1. I tried to use python3 runserver on my instance, and found out that the files were updated fine , therefore the issue was with the production side

  2. I figured out that only static and html files were being updated (nginx serves those) , so the problem was not with that

  3. I was using gunicorn to help with the and and other such files, so the problem could be with gunicorn


So I ran the command sudo systemctl restart gunicorn, and the code worked perfectly

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel