WP White Screen problem, with a difficult unique twist • GENIUS SERVER PEOPLE WANTED!

August 9, 2014 1.6k views

Below is a longish tech Support Ticket I have had going on with DO Support for the last 24 hours. Unfortunately, they have not been able to help me out, so I am turning to the Community for some much needed help. Here are the details;

• Site in question is http://fxnightlife.com
• Server is 2Gig One-Touch LAMP creation with Ubuntu 14.04
• Virtual Hosts are on here, followed the DO tutorial precisely in setting those up
• First WP site I created on this server is http://digitera.agency which is working well so far (although not without some permissions issues)

I'll let you read the Tech Support Ticket below (reads from bottom to top, as I just copied it straight from support). The big issue seems to be the errors in pulling http://mydigitera.com which I have NO idea where they're coming from.

Any genius server people care to take a stab at this?

<hr>

Greetings,

I recommend that you try to get more eyes on your issue by reaching out to our community and include a description of what you are trying to accomplish along with what you've done so far. It's very likely that your issue has been addressed before.

https://www.digitalocean.com/community/questions

Chat: http://webchat.freenode.net/?channels=digitalocean&uio=d4

Please let us know if we can be of further assistance.

Regards,
Brad
DigitalOcean Support Team

Posted on 08/09/14 at 20:40 UTC
Gravatar Brad
Doesn't look like it returned anything...if I'm doing it wrong, feel free to correct me.

http://pastebin.com/5TppDG7N

Posted on 08/09/14 at 20:11 UTC
Gravatar Info
Thank you for providing this detail.

May I have you provide log data specific to requests for the affected site? I'd like to filter out data for the other sites.

I tested a series of requests from 73.183.177.185, if you could provide the output of the following, it may be useful:

grep 73.183.177.185 /var/log/apache2/error.log

I only made requests to http://fxnightlife.com/, so it should limit results to errors pertaining to my requests.

Thanks,
DigitalOcean Support
Check out our community for helpful articles and tutorials.
https://digitalocean.com/community

Posted on 08/09/14 at 20:05 UTC
Gravatar Jmarhee
• For mydigitera.com.conf (http://mydigitera.com is meant to be a one page redirect to http://digitera.agency which is what you see when you navigate there).

http://pastebin.com/ndJpdpDE

• For fxnightlife.com.conf (the site with the problems)

http://pastebin.com/z1pV9RrG

• For digitera.agency.conf (the other WordPress site I have on this server that actually works)

http://pastebin.com/tT6NcdAw

Posted on 08/09/14 at 19:48 UTC
Gravatar Info
Hello,
Actually I think you hit the nail right on the head as this sounds exactly like it is pulling that domain from the conf file. Can you pastebin us the conf file that is not being read as we would be more than happy to review it!

-Josh

Posted on 08/09/14 at 18:53 UTC
Gravatar Josh
I saw that as well. What perplexes me is that the install at http://fxnightlife.com is a fresh one, and therefore does not contain any reference to http://mydigitera.com at all. Also, why would http://digitera.agency work fine and http://fxnightlife.com not work? They're both on the same server here, as you can see.

Some guidance questions...

• How can I check the script that is trying to access http://mydigitera.com ? None of my current installs on the Digitera01 server are supposed to be accessing that domain...I want to remove whatever is making these pull requests.

• Might this pull be something within one of those CONF files that the Virtual Hosts tutorial deals with?

I'm really stumped here....any guidance you can give me will be much appreciated.

Posted on 08/09/14 at 17:48 UTC
Gravatar Info
Hello

Looks like your site is trying to load "/var/www/mydigitera.com/html/wp-login.php" and that currently is not there.

Can you check to make sure that the paths and files are all proper and data is there?

Thanks
Support

Posted on 08/09/14 at 09:02 UTC
Gravatar Gd
/var/log/apache2/error.log

[Fri Aug 08 00:30:05.696544 2014] [:error] [pid 9804] [client 183.60.215.38:32913] script '/var/www/mydigitera.com/html/wp-login.php' not found or un$
[Fri Aug 08 05:22:44.902318 2014] [:error] [pid 5829] [client 217.69.133.28:57475] script '/var/www/html/index.php' not found or unable to stat
[Fri Aug 08 07:02:36.153460 2014] [:error] [pid 9804] [client 94.242.239.177:54116] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$
[Fri Aug 08 08:29:47.332995 2014] [:error] [pid 10810] [client 183.60.215.38:36205] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$
[Fri Aug 08 09:44:12.667476 2014] [:error] [pid 13881] [client 183.60.214.126:54451] script '/var/www/mydigitera.com/html/wp-login.php' not found or $
[Fri Aug 08 10:15:21.970918 2014] [:error] [pid 10986] [client 217.69.133.192:38244] script '/var/www/html/index.php' not found or unable to stat
[Fri Aug 08 10:19:16.250109 2014] [:error] [pid 13876] [client 58.23.18.129:7322] script '/var/www/mydigitera.com/html/wp-login.php' not found or una$
[Fri Aug 08 11:53:54.923313 2014] [:error] [pid 9804] [client 66.249.69.140:48052] script '/var/www/html/piwik.php' not found or unable to stat
[Fri Aug 08 13:04:06.447846 2014] [:error] [pid 10988] [client 183.60.215.38:56921] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$
[Fri Aug 08 13:53:50.180098 2014] [:error] [pid 5829] [client 183.60.213.38:53122] script '/var/www/mydigitera.com/html/wp-login.php' not found or un$
[Fri Aug 08 14:23:15.500521 2014] [:error] [pid 8113] [client 183.60.213.38:58107] script '/var/www/mydigitera.com/html/wp-login.php' not found or un$
[Fri Aug 08 14:52:06.370395 2014] [:error] [pid 29355] [client 183.60.213.38:47881] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$
[Fri Aug 08 14:59:37.991149 2014] [:error] [pid 415] [client 183.60.215.38:49676] script '/var/www/mydigitera.com/html/wp-login.php' not found or una$
[Fri Aug 08 15:13:03.920838 2014] [:error] [pid 29355] [client 183.60.214.126:37010] script '/var/www/mydigitera.com/html/wp-login.php' not found or $
[Fri Aug 08 15:46:08.930757 2014] [:error] [pid 9407] [client 183.60.213.38:55796] script '/var/www/mydigitera.com/html/wp-login.php' not found or un$
[Fri Aug 08 15:51:13.560931 2014] [:error] [pid 29361] [client 183.60.215.38:42810] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$
[Fri Aug 08 19:50:39.800011 2014] [:error] [pid 26612] [client 77.87.78.85:50565] script '/var/www/mydigitera.com/html/wp-login.php' not found or una$
[Fri Aug 08 20:22:57.300008 2014] [:error] [pid 18628] [client 183.60.214.126:56517] script '/var/www/mydigitera.com/html/wp-login.php' not found or $
[Fri Aug 08 21:45:14.506201 2014] [:error] [pid 21884] [client 183.60.214.126:39839] script '/var/www/mydigitera.com/html/wp-login.php' not found or $
[Fri Aug 08 22:52:47.560167 2014] [:error] [pid 26612] [client 183.60.215.38:53618] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$
[Fri Aug 08 23:09:30.696791 2014] [:error] [pid 415] [client 66.249.85.109:62581] PHP Notice: Constant WPDEBUG already defined in /var/www/fxnightl$
sendmail: warning: /etc/postfix/main.cf, line 59: overriding earlier entry: virtual
aliasmaps=hash:/etc/postfix/virtual
postdrop: warning: /etc/postfix/main.cf, line 59: overriding earlier entry: virtual
alias_maps=hash:/etc/postfix/virtual
[Sat Aug 09 00:53:39.539392 2014] [mpm_prefork:notice] [pid 16721] AH00169: caught SIGTERM, shutting down
[Sat Aug 09 00:53:40.610659 2014] [mpm_prefork:notice] [pid 25001] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.3 configured -- resuming normal $
[Sat Aug 09 00:53:40.610759 2014] [core:notice] [pid 25001] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 09 01:17:23.887825 2014] [mpm_prefork:notice] [pid 25001] AH00169: caught SIGTERM, shutting down
[Sat Aug 09 01:17:24.990037 2014] [mpm_prefork:notice] [pid 28239] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.3 configured -- resuming normal $
[Sat Aug 09 01:17:24.990134 2014] [core:notice] [pid 28239] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 09 03:16:17.937630 2014] [:error] [pid 28255] [client 183.60.215.38:60113] script '/var/www/mydigitera.com/html/wp-login.php' not found or u$

/var/www/httpd/error.log

No file existed for this path


Jordan St Jacques
Digitera Interactive

613-263-4144 for Canada
617-401-7773 for USA


From: DigitalOcean support@support.digitalocean.com
Sent: Saturday, August 9, 2014 12:49 AM
To: Digitera Email
Subject: [DigitalOcean Ticket ID:338932] WordPress install

There has been a response to your ticket:

Hello there,

Can you please provide us with the last 25 lines of the http servers error log? This can generally be found in /var/log/apache2/error.log and /var/www/httpd/error.log

Once we have these we should be able to help you figure out what might be going on there.

Let us know if you have any questions,

Harry
DigitalOcean Support
Check out our community for helpful articles and tutorials.
https://digitalocean.com/community


Please log-in to your DigitalOcean Control Panel to view your reply: https://cloud.digitalocean.com/support/338932

Posted on 08/09/14 at 07:58 UTC
Gravatar Info
What's most perplexing about all of this is that I followed the same tutorials for http://digitera.agency/ and that one worked out fine.....not so much for http://fxnightlife.com/ though

Posted on 08/09/14 at 05:19 UTC
Gravatar Info
Further to last comment.....went into Bash and deleted the theme folder....still nothing

Posted on 08/09/14 at 05:07 UTC
Gravatar Info
OK, update....here's what I did after verifying the Virtual Hosts were working properly;

• reinstalled Wordpress using root user
• got as far as the initial WordPress install screen where you fill out the name of the site etc
• got an error when submitting than page
• adjusted CHMOD to 777 for wp-admin directory
• went back to that page and was succesful in creating WP finally
• logged into WP backend, tried to install a theme, got prompted for FTP/SSH login credentials in order to install said theme
• supplied info, theme installed properly
• was able to install a background image, favicon and logo into the theme
• in the middle of my next simple operation...BANG! White screen of death on the frontend and a 404 error on the backend.
• Tried adjusting the CHMOD for the entire fxnightlife.com folder and everything underneath to 777
• no luck

Please help.

Posted on 08/09/14 at 05:06 UTC
Gravatar Info
Hello there,

Can you please provide us with the last 25 lines of the http servers error log? This can generally be found in /var/log/apache2/error.log and /var/www/httpd/error.log

Once we have these we should be able to help you figure out what might be going on there.

Let us know if you have any questions,

Harry
DigitalOcean Support
Check out our community for helpful articles and tutorials.
https://digitalocean.com/community

Posted on 08/09/14 at 04:49 UTC
Gravatar Harry Richardson
Actually, I deleted everything, and stuck up a simple index.html file under /var/www/fxnightlife.com/html/ and I'm still getting white screen. Now, I'm really stumped....because on my working computer I'm still showing a white screen of death, but on another laptop the index.html file propagates ok.

Posted on 08/09/14 at 03:38 UTC
Gravatar Info
Hey,

Which domain is is that's having the issue?

The most likely cause, based on what you've told us, is that the permissions on this folder aren't set correctly. Can you go to the folder holding your web content and show us the output of ls -lah?

You might wish to compare this to your fxnightlife folder.

Best,
Michael

Posted on 08/09/14 at 03:34 UTC
Gravatar Michael
One more fact....php.ini already had a memory limit set for 128M

Posted on 08/09/14 at 03:24 UTC
Gravatar Info
Thanks for the article, but it didn't shed any light. Here are some more specifics;

• This is a new fresh install of WordPress
• The Virtual Host was setup days ago
• The DNS was switched over to DO nameservers about 6pm EST today
• DNS tests show all is good there
• There are NO plugins or themes installed yet
• Arrived at White Screen of Death immediately upon completing the WordPress tutorial
• I have another site on the same Server called http://digitera.agency that works fine...only difference is that I set it up under the root user
• The instance at http://fxnightlife.com was setup under the user "fxwpuser"

If you can push me in the proper direction here, that would be great.

Posted on 08/09/14 at 03:14 UTC
Gravatar Info
Hello,

I recommend that you check out the following article from our community:

How to Fix the WordPress White Screen of Death
http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-wordpress-white-screen-of-death/

Please let us know if we can assist you further.

Best regards,
Brad
DigitalOcean Support Team

Posted on 08/09/14 at 03:02 UTC
Gravatar Brad
Followed these two tutorials in trying to setup http://fxnightlife.com as a Virtual Host on my Server;

https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-14-04-lts

https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-on-ubuntu-14-04

When I try to navigate to that URL, I get a blank white screen. Any thoughts on what I can do to troubleshoot this issue?

Posted on 08/09/14 at 02:41 UTC

1 comment
  • Does /var/www/fxnightlife.com/html exist? What's the output of ls /var/www/fxnightlife.com/html?

1 Answer

Solved....it was the theme that was the problem.

Have another answer? Share your knowledge.