Question

X2go Windows Client Won't Connect

Connected Tutorial
This question is a follow-up to this tutorial:

I followed the setup guide to the letter, and after installing the X2Go client on my Windows 10 machine, I tried connecting the session the guide helped me create. The X2Go UI said, “connecting”, and then asked if I wanted to trust the key of the server, I said yes, and waited a short while.

Then an Error dialogue appeared that said “bash: line 1: x2golistsessions: command not found”. Then I clicked OK and got shown a password login dialogue on the X2Go client. I tried that with the same resulting error. How can I go about troubleshooting this error? I am running Ubuntu 20.10 on my droplet.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

Have you tried restarting your Windows PC after you installed the client?

Also what I could suggest is checking your X2Go logs for some more information on what could be going wrong.

Feel free to share the output of the logs here.

Best,

Bobby