Question

Yandex unable to see MX setup

Hi;

I created to one of my domains an MX Record for Yandex mail service. It’s been two days and I still get “Verified but missing MX record” error. when i try to configure MX record on “connect.yandex.ru/pdd” i get the error “Invalid MX record”

the records that i setup on my cloud are shown below :

https://deephouse.com.tr/cloud.jpg

Thanks for your patience…


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello Alex and thank you.

Changing “mail”.devreguvenlik.com.tr" to “@”.devreguvenlik.com.tr helped me.

It works now…

Thanks for your patience

Hello Alex;

Nothing is changed after one more day. It’s more than 72 hours and i couldn’t make Yandex see the MX records.

I will try “yandex.com” instead of “mx.yandex.com” and sadly, wait for 2 more days :(

Regards…

Hello, @hakanceliker

At the moment your MX is not working/resolving. Would you mind set the MX record to be domain.com instead of mx.domain.com and then point to mx.yandex.net

You can also monitor the DNS propagation using any website like: https://www.whatsmydns.net

Keep in mind that DNS changes might take up to 48 hours in order to fully propagate. This happens because of DNS cache from ISPs. However it usually happens a lot faster.

Let me know how it goes.

Regards, Alex