You have an error in your SQL syntax; Neeed Help

December 4, 2013 2.1k views
When installing wordpress I get this error when adding a semi colon at the end CREATE DATABASE WP1; ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ': Is there any faster or less complicated way to install WP. I am used to cpanel 1-click install
2 Answers
With "faster or less complicated" you end up sacrificing performance. If that's what you want, check out One-Click Install WordPress on Ubuntu 12.10 with DigitalOcean.

If performance matters to you, check out a href="https://www.digitalocean.com/community/articles/how-to-install-wordpress-nginx-php-and-varnish-on-ubuntu-12-04">How To Install Wordpress, Nginx, PHP, and Varnish on Ubuntu 12.04.

You may also be interested in How To Use Filezilla to Transfer and Manage Files Securely on your VPS.
by Etel Sverdlov
Varnish is an HTTP accelerator and a useful tool for speeding up a server, especially during a times when there is high traffic to a site. It works by redirecting visitors to static pages whenever possible and only drawing on the server itself if there is a need for an active process. This tutorial covers installing wordpress on a LEMP stack (with nginx instead of apache), and then installing varnish.
What command are you trying to run exactly?
Have another answer? Share your knowledge.