6to4 within DO on Ubuntu

I need to get IPv6 connectivity to my droplet up and running and I figured I’d use 6to4 for a quick and easy setup.

Ubuntu 14.04 makes it easy. In the interfaces file:

auto tun6to4 iface tun6to4 inet6 6to4 local 162.243.xx.xx (IP of eth0) mtu 1480

Nice and simple. :)

interface: 25: tun6to4: <NOARP,UP,LOWER_UP> mtu 1480 qdisc noqueue state UNKNOWN group default link/sit 162.243.xx.xx brd inet6 2002:a2f3:xxxx::1/16 scope global valid_lft forever preferred_lft forever

route entry: 2000::/3 via :: dev tun6to4 metric 1024

I receive any packets going to 2002:a2f3:xxxx::/16 but outgoing packets don’t get to their destination. I’ve checked a packet capture and yes, the outgoing packets are correctly formed.

Has anyone else had luck?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

HI @michael200338 did you ever get this figured out?

@Kamal that tutorial is old and no longer applies to Ubuntu 14.04 which has the ability to accomplish the same thing solely with the snippet I pasted in my question.

I’m pretty sure that /etc/interfaces config is enough. Try setting up a 6to4 tunnel as described in this tutorial: <a href=“”></a>. <br> <br>Let me know how it goes!