Apache 2 SSL input read failed

Hello everyone,

I have configured in my Debian 7 droplet the Apache 2 web server with a SSL enabled virtual host. The host seems to serve the content properly (it’s a small sample HTML) but I keep getting these errors in error-ssl.log:

[info] [client] Connection to child 8 established (server <DNSHOSTNAME>:443) [info] Seeding PRNG with 656 bytes of entropy [info] Initial (No.1) HTTPS request received for child 8 (server <DNSHOSTNAME>:443) [info] [client] (70007)The timeout specified has expired: SSL input filter read failed. [info] [client] Connection closed to child 8 with standard shutdown (server <DNSHOSTNAME>:443)

Anyone knows how is “The timeout specified has expired: SSL input filter read failed.” message caused? I have been searching all over the place for this, and it seems that people have a totally different configuration than mine. Any ideas?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

We are facing the same issue. We have configured apache with Ssl as a proxy to backend services, The timeout issue occurs randomly without any specific pattern and the configuration of KeepAlive is also of no help (MaxKeepAliveRequests etc).

Has anyone found the solution to it ?

I haven’t followed a specific guide. I just enabled the SSL virtualhost and setup my Certificates according to standard procedure. The next steps was to strengthen SSL security by following this guide: <br> <br> <br>Has anyone stumbled in this message before? It is categorized under info, but it is clear that something is wrong.

<b>“I have configured … the Apache 2 web server with a SSL …”</b> <br> <br>Did you follow a guide, when you did that? If so, which one?