Question

Apache configuration not serving content

I was following this tutorial on connecting domains and setting up Apache virtual hosts. However, when I try to reach my domain, I get ERR_EMPTY_RESPONSE. I’ve tried a few fixes after searching around including altering the apache2.conf <Directory> blocks “AllowOverride” settings and adding my own to the domain name .conf file.

My configuration looks as follows:

<VirtualHost *:80>
	ServerName skasandbox.com
	ServerAlias www.skasandbox.com
	ServerAdmin admin@skasandbox.com
	DocumentRoot /var/www/skasandbox.com/public_html
	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

The directory settings I tried (inside said file) were:

	<Directory /var/www/ssandbox.com/public_html/>
	  Options FollowSymLinks
	  AllowOverride All
	  Require all granted
	</Directory>

There is a basic index.html file inside /var/www/ssandbox.com/public_html. I’ve set up an A record for bot @ and www pointing to my Droplet IP Adress. I can ping the site and get a response from the droplet. Any help would be greatly appreciated. I do not know what I’m doing wrong as most information for setting this up is nearly identical to the Digital Ocean tutorial.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @skasolutions

Could you please clarify if you’re still experiencing the issue? At the moment the website is loading just fine tested from my end. The site is serving a default WordPress page.

Regards, Alex