Question

Build of Rails app on app platform fails early

Created an app using the app builder for my rails app. Then tried to deploy it, which resulted in a failure and this log…

[2022-05-18 11:17:49] => Initializing build
[2022-05-18 11:17:49] => Retrieving source code to /workspace
[2022-05-18 11:17:49] => Selecting branch "master"
[2022-05-18 11:18:05] => Checking out commit "da3767f507028ec29efcf4be7f478714cc4866f2"
[2022-05-18 11:18:11] => Got source_dir: /
[2022-05-18 11:18:11] => Using workspace root /workspace
[2022-05-18 11:18:11] 
[2022-05-18 11:18:11] => Building app using buildpacks
[2022-05-18 11:18:12] => Running buildpack detection
[2022-05-18 11:18:12] 
[2022-05-18 11:18:12] 4 of 5 buildpacks participating
[2022-05-18 11:18:12] heroku/nodejs-engine        0.5.1
[2022-05-18 11:18:12] heroku/ruby                 0.230.2
[2022-05-18 11:18:12] digitalocean/ruby-appdetect 0.0.2
[2022-05-18 11:18:12] digitalocean/procfile       0.0.3
[2022-05-18 11:18:12] 
[2022-05-18 11:18:12] For documentation on the buildpacks used to build your app, please see:
[2022-05-18 11:18:12]    Ruby: https://do.co/apps-buildpack-ruby
[2022-05-18 11:18:13] 
[2022-05-18 11:18:13] => Building app
[2022-05-18 11:18:13] 
[2022-05-18 11:18:13] ---> Node.js Buildpack
[2022-05-18 11:18:13] ---> Installing toolbox
[2022-05-18 11:18:13] ---> - jq
[2022-05-18 11:18:13] ---> - yj
[2022-05-18 11:18:15] ---> Getting Node version
[2022-05-18 11:18:15] ---> Resolving Node version
[2022-05-18 11:18:17] ERROR: failed to build: exit status 1
[2022-05-18 11:18:18] 
[2022-05-18 11:18:18] For documentation on the buildpacks used to build your app, please see:
[2022-05-18 11:18:18]    Ruby: https://do.co/apps-buildpack-ruby
[2022-05-18 11:18:18] 
[2022-05-18 11:18:18]  ! Build failed (145)
[]

Not very helpful :(

Can anyone tell me how to debug this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @joelflish,

What’s Rails version are you using?, weckpacker require clearing cache before every deploy.

In addition, node-sass can generate deployments problems. You can try adding:

"postinstall": "npm rebuild node-sass"

to your package.json file.

Let me know how it goes!

Cheers, Sergio Turpín